Не запускается при старте runtime OPCLink

Обсуждение SCADA-системы Wonderware: InTouch ME, InTouch Edge HMI, InTouch, InTouch OMI и System Platform
Андрей
Сообщений в теме: 2
Сообщения: 39
Зарегистрирован: 28 фев 2011, 11:39

Не запускается при старте runtime OPCLink

#1

Сообщение Андрей » 24 май 2011, 14:01

Настроил связь между контроллером и InTouch через OPC. Получил следующую ситуацию... Если запускаю сначала OPCLink, а потом InTouch Runtime все отлично работает! Если же запускаю сначала InTouch Runtime, то получаю следующие сообщения об ошибках:

opclink_error1.PNG

Пытаюсь сказать да, что надо запусать, и получаю в ответ следующее сообщение:

opclink_error2.PNG

Вообще не пойму в чем дело!?
У вас нет необходимых прав для просмотра вложений в этом сообщении.



Андрей
Сообщений в теме: 2
Сообщения: 39
Зарегистрирован: 28 фев 2011, 11:39

Re: Не запускается при старте runtime OPCLink

#2

Сообщение Андрей » 24 май 2011, 16:52

Похоже что нет никаких средства автоматического запуска OPCLink.exe одновременно с запуском Runtime. Только вручную запускать перед стартом или же включать его запуск как сервис (Menu->OPCLink Settings и выбрать Start automatically as Windows NT Service) :(



4eremis
Сообщений в теме: 1
Сообщения: 2
Зарегистрирован: 22 мар 2012, 08:16

Re: Не запускается при старте runtime OPCLink

#3

Сообщение 4eremis » 22 мар 2012, 08:43

Андрей писал(а):Похоже что нет никаких средства автоматического запуска OPCLink.exe одновременно с запуском Runtime. Только вручную запускать перед стартом или же включать его запуск как сервис (Menu->OPCLink Settings и выбрать Start automatically as Windows NT Service) :(

Можно написать ява скрипт который будет запускать сначало OPCLink.exe а потом с задержкой WScript.Sleep(5000); и сам интачь. Можно закинуть этот файл и в автозагрузку.




Если эта тема может быть полезна другим, поделитесь ссылкой:

Вернуться в «Wonderware: InTouch ME, InTouch Edge HMI, InTouch, InTouch OMI и System Platform»